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Overview 1
 The BlackBerry® Java® Plug-in for Eclipse® extends the Eclipse development framework to enable Java® developersto create BlackBerry® applications and MIDlets for BlackBerry devices. In Eclipse and Eclipse based IDEs, theBlackBerry Java Plug-in for Eclipse provides the tools to create, debug, optimize, and localize Java applications forBlackBerry devices.
 The BlackBerry Java Plug-in for Eclipse adds functionality and features to the Eclipse IDE that can help simplify Javaapplication development for BlackBerry devices while giving you access to standard Eclipse tools, such as code assist.The BlackBerry Java Plug-in for Eclipse includes the BlackBerry® Java® SDK 6.0 with corresponding BlackBerry APIs,and a BlackBerry® Smartphone Simulator .
 You can create BlackBerry device applications for different versions of the BlackBerry® Device Software. When yourun a BlackBerry device application, the BlackBerry Java Plug-in for Eclipse starts the BlackBerry Smartphone Simulatorautomatically.
 Release Notes Overview
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What's new in this release 2
 Feature Description
 BlackBerry® ApplicationDevelopment perspective
 The BlackBerry Application Development perspective gives you quick access to thedevelopment tools that you need to create BlackBerry device applications. Theperspective provides a toolbar and a menu that bring all the tools together in oneplace.
 BlackBerry applicationproject templates
 Templates for BlackBerry application projects help you get started quickly. You cancreate a basic UI application by using a template and then customize the code tosuit your needs, or you can start your application from scratch by using an emptytemplate.
 UI screen templates The BlackBerry® Java® Plug-in for Eclipse® provides three UI screen templates forscreen layouts that are typically used in BlackBerry device applications.
 Faster debugging Increased speed helps you step through code faster.
 Support for BlackBerry®Java® SDK 6.0
 The setup application for the BlackBerry Java Plug-in for Eclipse includes theBlackBerry Java SDK 6.0.
 Support for Eclipse® 3.6(Helios)
 The setup application for the BlackBerry Java Plug-in for Eclipse includes Eclipse 3.6.
 Dynamic Getting Startedpages
 The Getting Started pages are updated dynamically over the Internet, providing youwith access to the latest articles, tutorials, and links to information about developingJava® applications for BlackBerry devices.
 Automatic versiondetection
 The BlackBerry Java Plug-in for Eclipse notifies you automatically when a newversion is available.
 Release Notes What's new in this release
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Fixed issues 3
 This section lists fixed issues for the BlackBerry® Java® Plug-in for Eclipse®.
 BlackBerry Smartphone Simulator
 When you used Windows 7 (64-bit), when you ran or debugged a BlackBerry device application that you createdin the BlackBerry JRE™ 5.0 or earlier in the BlackBerry® Smartphone Simulator, the simulator did not close whenyou clicked the close button (X) at the top-right of the simulator screen. (1076015)
 Localization
 After you renamed a locale resource package, when you opened a resource file in the new package location, thefile was not found. (1045766)
 Workspaces and projects
 When you createda new BlackBerry application project, in the project properties, the Version field and the Vendorfield did not match the default values set in Window > Preferences > BlackBerry Java Plug-in. (1041320)
 When you packaged a BlackBerry application project, in the Working Sets dialog, if you selected the No WorkingSets option, when you clicked OK, you encountered an Unhandled event loop exception. (1065149)
 Unclassified
 In the BlackBerry_App_Descriptor.xml file, the Home Screen Position field accepted invalid values, for example-1 or 256. (1041312)
 Release Notes Fixed issues
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Known issues 4
 This section lists known issues for the BlackBerry® Java® Plug-in for Eclipse®.
 Installing
 If you want to install multiple versions of the BlackBerry® Java® SDK, you must specify your login credentials foreach SDK. (545417)
 Impact: You must log in every time you want to install an SDK.
 Workaround: You can cache your password so that, after the first installation, you do not have to enter yourcredentials. In the login dialog box, select the check box.
 When you install a BlackBerry Java SDK in Eclipse 3.5.1, a warning about unsigned .jar files displays. (427122)
 Impact: You must dismiss the warning every time you install a component.
 Workaround: None.
 When you install the BlackBerry Java Plug-in for Eclipse by using the BlackBerry update site, if the .../configuration/config.ini file is not writeable by the Eclipse osgi.framework or by Eclipse Pulsar, a preprocessor hook loop iscreated. (578783)
 Impact: You are continually prompted to configure and restart Eclipse.
 Workaround 1: Edit the .../configuration/config.ini file to add or append the following text:osgi.framework.extensions=[<other-ref>,]reference\:file\:net.rim.ejde.preprocessing.hook_1.1.2.<date-ver>.jar (as installed, for example, :net.rim.ejde.preprocessing.hook_1.1.2.201003212304-12.jar).
 Workaround 2: Edit the eclipse.ini file to add or append the following text: -Dosgi.framework.extensions=[<other-plug-in>,]net.rim.ejde. Use this workaround for Eclipse Pulsar.
 When you upgrade from the BlackBerry Java Plug-in for Eclipse 1.x to 1.1.2, signing keys are not transferredautomatically. (579957)
 Impact: You cannot sign BlackBerry device applications.
 Workaround: You can install the keys manually by using Window > Preferences > BlackBerry Java Plug-in >Signature Tool > Import Existing Keys. Navigate to the location where the keys were previously installed (forexample, /plugins/net.rim.ejde/signTool for the BlackBerry Java Plug-in for Eclipse 1.1.1).
 Release Notes Known issues
 5

Page 8
                        

Debugging
 When you debug a BlackBerry device application on a secure device, after the application encounters a breakpoint, when you open theVariables view you might encounter the message: not available - unsupported by VMfor some variables. (1131217)
 Impact: You are unable to view the details about some variables when you debug your application on a securedevice.
 Workaround: Expand the variable to observe other inner fields or debug your application by using the BlackBerrySmartphone Simulator.
 In Eclipse®, when you select a variable in the detail pane, the detail formatter issues an error message. (1036094)
 Impact: Descriptive text about the variable that is selected is not displayed.
 Workaround: None.
 When you debug your BlackBerry device application by using step filtering, Filter by Package does not work.(900918)
 Impact: You cannot use Filter by Package to debug your application.
 Workaround: After you select Filter by Package, click Window > Preferences > Java > Debug > Step Filtering;check the Use Step Filters check box.
 When you hot-swap a BlackBerry device application that uses resource keys, if you change a resource key, theapplication is not updated when you resume hot-swapping. (762467)
 Impact: Your application is not updated after you change a resource key while hot-swapping.
 Workaround: Close the application before hot-swapping.
 When you debug your BlackBerry device application by hot-swapping, if you remove a field from a persistentinstance, when you relaunch your application, hot-swap does not stop. (743487)
 Impact: You must restart the simulator before you can continue to hot-swap the updated application.
 Workaround: None.
 If you move the BlackBerry Java Plug-in for Eclipse to a new location, you cannot use the BlackBerry® SmartphoneSimulator. (545814)
 Impact: You cannot change the location of the BlackBerry Java Plug-in for Eclipse by moving or renaming the folder.
 Workaround: Click Project > BlackBerry > Clean Simulator to clean the simulator then launch the simulator again.
 If you start debugging a project with breakpoints and then change the BlackBerry JRE, the debugger does notprovide output. (557517)
 Release Notes Known issues
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Impact: You cannot view debugging information.
 Workaround: Restart Eclipse.
 When you create a BlackBerry device launch configuration and select the option to attach to a specific device, theBlackBerry Java Plug-in for Eclipse does not prevent you from starting to debug without specifying the device. Inaddition, the list of available devices does not reflect the devices that are currently attached even after selectingthe option to refresh the list. (535402)
 Impact: You can attempt to attach a debugger to a specific device without selecting a device. You cannot refreshthe list of available devices to attach to the debugger.
 Workaround: Do not create a device launch configuration that attaches to a specific device without specifying thedevice.
 If you create two BlackBerry launch configurations, the BlackBerry Java Plug-in for Eclipse does not prevent youfrom launching both sessions. Both sessions might not start. (534772)
 Impact: You cannot run multiple debug sessions.
 Workaround: Do not start multiple debug sessions.
 If you have two BlackBerry application projects that contain Java files with the same name, when you debug theproject, the BlackBerry Java Plug-in for Eclipse might open the wrong source file. (298096, 518682).
 Impact: When you debug your application the wrong source file is opened.
 Workaround: On the Debug Configurations > Source tab, select Search for duplicate source files on the path andrename any duplicate file names.
 When you debug a BlackBerry device application, the BlackBerry profiler view automatically closes when thedebugger terminates. (354545).
 Impact: You cannot view BlackBerry profiler information after the debugger terminates.
 Workaround: None.
 When you click Debug as > Running BlackBerry Simulator to invoke a debug session for a BlackBerry deviceapplication, the debugger does not terminate when the BlackBerry Smartphone Simulator terminates. (410786)
 Impact: You must manually stop the debugger.
 Workaround: None.
 When you debug a BlackBerry device application by using Run > Debug as > Running BlackBerry Simulator, theapplication is not loaded automatically onto the BlackBerry Smartphone Simulator. (487482)
 Impact: The application is not loaded automatically onto the BlackBerry Smartphone Simulator.
 Workaround: You must load the application manually onto the BlackBerry Smartphone Simulator.
 Release Notes Known issues
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When you protect a BlackBerry device application with a private key, the application is not signed automatically.(508277)
 Impact: When you debug the application in the BlackBerry Smartphone Simulator you might encounter an error.
 Workaround: You must sign the application manually by using the BlackBerry® Signing Authority Tool.
 After you debug a BlackBerry device application in the BlackBerry Smartphone Simulator, if you run the applicationfrom Eclipse and then close the simulator, the simulator does not stop. (512588, 532712)
 Impact: When you run or debug the next BlackBerry device application you encounter an error and you cannotclean the simulator.
 Workaround: Restart Eclipse.
 When you comment out a line of executable code that has a toggled break point, the break point is not removed.(559282)
 Impact: The debugger will suspend execution at the commented line.
 Workaround: None.
 BlackBerry Smartphone Simulator
 When you use Windows® 7 64-bit, if you test your BlackBerry device application on a BlackBerry® SmartphoneSimulator that you installed outside the Eclipse environment in an access-controlled directory, contact andpassword information may not be deleted when you run Clean Simulator. (1112690)
 Impact: Sensitive contact and password information may persist beyond the intended lifecycle.
 Workaround: Log in with System Administrator privileges when you install a BlacBerry Smartphone Simulator andwhen you use the BlackBerry Java Plug-in for Eclipse.
 When you hotswap your BlackBerry device application on the BlackBerry Smartphone Simulator, if you removethe icon for the application and set the idle and rollover icons externally, when you re-deploy the application tothe BlackBerry Smartphone Simulator and then close the application, the application icon on the simulator is resetto the default icon. (1063282)
 Impact: The icon for your application is reset to the default icon.
 Workaround: Do not change the icon type for your application while hot-swapping the application on theBlackBerry Smartphone Simulator.
 When you run your BlackBerry device application on the BlackBerry Smartphone Simulator, console output isinterrupted with the string "[0.0]" at the beginning of each line at fixed intervals. (1055525)
 Impact: Console output may be difficult to interpret.
 Release Notes Known issues
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Workaround: Ignore.
 After you install an external BlackBerry Smartphone Simulator, when you run or debug your BlackBerry deviceapplication, the BlackBerry devices that are supported by that simulator appear in the list of available devices evenif the devices are not supported by the selected BlackBerry JRE™. (1041335, 1041338)
 Impact: You might try to run your application on a simulator that does not support the BlackBerry JRE of yourapplication.
 Workaround:Select a device that is compatible with the BlackBerry JRE and the BlackBerry APIs that you use inyour application.
 When you run a BlackBerry device application in the BlackBerry Smartphone Simulator, if you launch the applicationa second time using a different BlackBerry JRE, you encounter a Port in Use error. (915337)
 Impact: You cannot launch an application that uses a different BlackBerry JRE while the simulator is in use.
 Workaround: Close the first instance of the application before you launch the second instance of the application.
 In the BlackBerry Smartphone Simulator, when you start a second instance of the web browser, you encounter anerror. (760450)
 Impact: You cannot run multiple instances of the web browser in the BlackBerry Smartphone Simulator.
 Workaround: None
 When you try to configure the BlackBerry Smartphone Simulator to use a file media card, the simulator does notrecognize the media card. (543853)
 Impact: You cannot configure the BlackBerry Smartphone Simulator to use a file media card.
 Workaround: You can configure a file media card when the BlackBerry Smartphone Simulator starts, or you canconfigure a file system media card by using a launch configuration.
 When you try to clear files from a simulated media card in the file system by using the clean simulator feature,the media card is not cleared and no error is displayed. (543845)
 Impact: You cannot clear a simulated media card by using the clean simulator feature.
 Workaround: You must manually delete the folder.
 If you configure a simulator media card and, in the SD Card Image field, you specify a path that includes a space,an error occurs indicating that there is an unrecognized argument.(543816)
 Impact: When you configure an SD Card image with a path that includes a space, you cannot use the BlackBerrySmartphone Simulator launch configuration.
 Workaround: You must enclose the path in quotation marks (").
 Release Notes Known issues
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When the BlackBerry Smartphone Simulator is running and you create a new run configuration that uses a differentBlackBerry JRE™ or simulator/device, the BlackBerry Java Plug-in for Eclipse prompts you to close the simulatorthat is currently running. If you close the simulator manually and then try to dismiss the prompt, the new simulatorlaunch configuration does not start. (543775)
 Impact: When the BlackBerry Smartphone Simulator is running, you cannot run a new launch configuration thatuses a different BlackBerry JRE or simulator/device.
 Workaround: Do not close the simulator manually. Allow Eclipse to close the simulator.
 When you run a MIDlet on the BlackBerry Smartphone Simulator and then make a change to the application, whenyou reload the application on the simulator, the change is not reflected on the simulator display and you encounteran exception when you close the application. (560007)
 Impact: You cannot change the MIDlet and then reload it while the application is running on the simulator.
 Workaround: Close the MIDlet application before you reload it on the simulator.
 If you are using a 64-bit operating system, you cannot close a BlackBerry Smartphone Simulator that you launchedoutside the BlackBerry Java Plug-in for Eclipse. (565499)
 Impact: You cannot close the BlackBerry Smartphone Simulator.
 Workaround: You must install FledgeHook.exe, a process monitoring program that can help close the BlackBerrySmartphone Simulator when the 'x' button is pressed. You can run FledgeHook.exe manually or as part of a batch(.bat) file that you use to start the BlackBerry Smartphone Simulator. You can find FledgeHook.exe in <Eclipse-install>/plugins/net.rim.ejde/vmTools. Note: 64-bit operating systems require 32-bit Java 1.6 and 32-bit Eclipse3.5.x.
 When you use Windows 7, if you install an external BlackBerry Smartphone Simulator in the default folder c:\Program Files, the BlackBerry Java Plug-in for Eclipse does not recognize the BlackBerry Smartphone Simulator.(587797)
 Impact: You cannot clean a BlackBerry Smartphone Simulator that is installed in the C:\Program Files folder.
 Workaround: You should install an external BlackBerry Smartphone Simulator in the root of the disk drive in afolder that has a shorter name. You must give the folder read-write permissions. Note: You can protect all .jarand .exe files by giving them read-only permission.
 Code signing
 When you package a BlackBerry application project that requires signing, after you sign the application once, youare not prompted for signature again until repacakaging is required. When you run the same application, you arealways prompted for signature.(1113779)
 Impact: There is an inconsistency between packaging and running your application when signature is required.
 Release Notes Known issues
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Workaround: None.
 If you configure your BlackBerry application project to automatically sign .cod files after packaging, when you runor debug the application, the BlackBerry® Signature Tool signs keys that are marked as optional. (533697)
 Impact: Some .cod files are unnecessarily signed.
 Workaround: None
 If you close Eclipse while the BlackBerry Signature Tool is running you cannot clean or package your BlackBerryapplication project. (531342)
 Impact: You cannot clean and package a project.
 Workaround: Close the signature tool manually.
 If you remove a .key file from a BlackBerry application project, the associated entries in theBlackBerry_App_Descriptor.xml file are not removed. (528274)
 Impact: After removing a .key file from a project, you receive an I/O error when you package the project.
 Workaround: Using a text editor, manually remove references to the .key file from theBlackBerry_App_Descriptor.xml file.
 When you run a BlackBerry device application on a secure device, if the application does not require signing, theBlackBerry Signature Tool prompts for signing. (467422)
 Workaround: None.
 Code signing warnings are displayed in the editor even when signing is not required. (490787)
 Impact: Unnecessary code signing warnings are displayed.
 Workaround: None.
 When your workspace in the BlackBerry Java Plug-in for Eclipse contains a mix of projects that are defined fordifferent BlackBerry JREs (from BlackBerry Java SDKs), after you import and package a project for a JRE, when youimport and package another project for a different JRE, the BlackBerry Signature Tool might not run. (605460)
 Impact: The .cod file might not be signed.
 Workaround: You can clean the project, sign the .cod file manually, or restart Eclipse.
 Workspaces and projects
 When you create a BlackBerry application project that depends on a Java® project, you may not be able to packagethe application or load it on a BlackBerry device. (1051705)
 Impact: You may not be able to package and deploy a BlackBerry application project that depends on a Java project.
 Release Notes Known issues
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Workaround: You can use either of the following methods:
 1. Create the dependent project as aBlackBerry library project rather than as a Java project and deploy itseparately on a BlackBerry device.
 2. Build your Java project as a separate library (JAR file) and include it in the .COD file of the BlackBerry applicationproject by adding the JAR file to the Java build path and exporting the JAR file.
 When you add a BlackBerry application project as a dependency to a Java project, you encounter an error.(1015170)
 Impact: A Java project cannot depend on a BlackBerry application project.
 Workaround: Use a BlackBerry project of the library type instead.
 After a user upgrades to a newer version of a BlackBerry device application, a duplicate entry for the applicationexists in Options > Applications, but only one version is accessible from the Home screen. (725671)
 Impact: BlackBerry device applications that are installed by using an .alx file have a different Application ID thanapplications that are installed by using a .jad file. Installing an application by using both methods can result in aduplicate entry on the BlackBerry device.
 Workaround: Build the .alx and .jad files to generate the same Application ID when the application is installed ona BlackBerry device.
 When you use Windows® 7 with Eclipse 3.5.0 or 3.5.1, if you change the BlackBerry_App_Descriptor to remove aresource file that is marked as invalid (for example, if you changed the file externally) from the Application Iconssection, you might encounter a stack overflow error. (601594)
 Impact: After you dismiss the error dialog, Eclipse exits and you must restart Eclipse.
 Workaround: Upgrade to Eclipse 3.5.2.
 You can create two identical preprocessors in the BlackBerry_App_Descriptor.xml. (538991)
 Impact: You can create a project descriptor with two identical preprocessors when you should not be able to.
 Workaround: Avoid creating two identical preprocessors, or you can delete or ignore the duplicate.
 If you try to clean a project more than once immediately after packaging, it might not complete successfully.(537756)
 Impact: You might not be able to clean the project.
 Workaround: None.
 When you create a BlackBerry application project that is a library and run the library application on the BlackBerrySmartphone Simulator, the library application has an associated default icon. (520519)
 Impact: Library applications appear with a default icon on the simulator when they should not have an icon.
 Release Notes Known issues
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Workaround: Using a text editor, in the BlackBerry_App_Descriptor.xml file, configure IsSystemModule to true,or you can ignore the icon.
 When you specify the properties for a BlackBerry application project, some fields might accept special characters(for example, @, $, %) that are not valid in the Eclipse development environment. (242681).
 Impact: When you run a BlackBerry application project, you might encounter application errors in the Eclipseworkspace.
 Workaround: Do not use special characters in BlackBerry application project properties.
 When you create a BlackBerry application project, if you use special characters (for example, @, $, %) in the projectname, you might encounter an XML validation error. (374640)
 Impact: You encounter an XML validation error when you run your application.
 Workaround: Do not use special characters in BlackBerry application project names.
 When you import a BlackBerry application project by linking the files rather than by copying the files, and youshare the project using the Perforce® plug-in for Eclipse, when you synchronize the project, you encounter anerror. (476444)
 Impact: You are unable to synchronize your project.
 Workaround: If the files are not in the Eclipse workspace, you can synchronize the files referenced by the linkoutside of Eclipse.
 When you update the BlackBerry Java Plug-in for Eclipse from version 1.1.1 to 1.1.2 and you launch a BlackBerryapplication project that you created in version 1.1.1, the default JRE in the workspace or in the project is notupdated. (560511)
 Impact: You cannot access the updated JRE in an application project that you created in the BlackBerry Java Plug-in for Eclipse 1.1.1.
 Workaround: Manually change the default JRE in Preferences > Installed JREs by editing the JRE to select the .eefile from the BlackBerry Java Plug-in for Eclipse 1.1.2.
 When you use the Import Existing Projects wizard to import by linking a project that was created by using theBlackBerry® JDE Plug-in for Eclipse 1.0, when you build the project, you might encounter an exception thata .preprocessed folder already exists. (538764)
 Impact: You might encounter an exception when you compile the project.
 Workaround: You must disable the Build Automatically option in Eclipse and refresh the project before buildingit.
 The following properties in the BlackBerry_App_descriptor.xml file do not correlate with the application type.(520325)
 Release Notes Known issues
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• Icons for Library type applications (if present before the switch) should be unavailable and not passed toRAPC.
 • Warnings for main(String[]) missing is valid only for the BlackBerry Application (CLDC) type.• Alias list makes sense only for Libraries, so it should be unavailable for other application types.• Auto-run on startup for Library applications makes sense if there is a libMain(String[]).
 Impact: Certain project properties do not correlate with the application type.
 Workaround: You must correlate the properties manually.
 Localization
 When you create a localized BlackBerry device application, after you create resource files for a locale other thanEnglish, when you launch the application, you encounter errors. (1092910)
 Impact: You are unable to run applications for locales other than English.
 Workaround: None.
 If you delete an application's language resource file while running the application in the BlackBerry SmartphoneSimulator, after the simulator relaunches the application, the resource file is still present. (537426)
 Impact: If you delete an application's language resource file while the application is running, after you relaunchthe application, the BlackBerry Smartphone Simulator displays the deleted resource.
 Workaround: When you want to delete a resource file, in the simulator, close the application. Delete the resourcefile and then launch the application.
 If you create a BlackBerry application project that has a library dependency and the library has language resourcefiles, you cannot set the Resource Title ID in the application project properties. (522311)
 Impact: You cannot use the resource files from a dependent library in your project.
 Workaround: None
 When you rename a BlackBerry device application package while an original locale file is open in the ResourceEditor, the original locale file is copied, not moved. (368943).
 Impact: You might have two copies of the original locale file.
 Workaround: Close the original locale file in the Resource Editor before you rename the package.
 When you use a version of Windows® that is not English, when you import a BlackBerry device project that containslocale resources, a pound currency symbol (£) is appended to the file name of the .crb file that is created in the /bin folder of the project. (494006)
 Impact: You cannot compile the BlackBerry application project.
 Release Notes Known issues
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Workaround: Use an English version of Windows, or in Windows, configure the Regional and Language Optionsto change the language for non-Unicode programs to English.
 When you specify a Description ID for a locale resource in the BlackBerry_App_Descriptor.xml file of yourBlackBerry application project, the description does not display if you build your application with BlackBerry JavaSDK 5.0. (506631).
 Impact: When you run the BlackBerry device application in the BlackBerry Smartphone Simulator, 'Unavailable'appears in the description field in Options > Applications > Core > <application name>.
 Workaround: None.
 Unclassified
 When you specify the version number of a MIDlet application on the BlackBerry Application Descriptor screenfor a BlackBerry project, if you type spaces or special characters in the Verison field, the characters are acceptedbut do not generate an error. (1103499)
 Impact: The special characters may cause unpredictable errors when running your application on a BlackBerrydevice.
 Workaround: Use a version definition that complies with the MIDlet specification by using three numeric segments,for example 1.2.3.
 If you create a MIDlet name that is 255 characters long, when you enter the name in the Name of main MIDlet classfield or in the Title field of an Alternate Entry Point (AEP) on the BlackBerry Application Descriptor screen, whenyou package your BlackBerry project, packaging fails. (1103724, 1103725)
 Impact: You cannot package your BlackBerry project.
 Workaround: Create MIDlet names that are shorter than 255 characters.
 In the BlackBerry Application Perspective, if you select text in the Eclipse editor while Convert String to Hex isenabled, when you change to another perspective, the conversion fails. (1037354)
 Impact: The Convert String to Hex feature does not work on highlighted text when you switch betweenperspectives.
 Workaround: None.
 When you save a linked contact, you encounter an UncaughtIllegalArgumentException. (743694)
 Impact: You cannot save a linked contact.
 Workaround: None.
 When you create a launch configuration and you change the default JRE, the description from the new projectBlackBerry JRE is not updated in the Runtime JRE dialog. (557094)
 Release Notes Known issues
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Impact: You do not see the correct runtime JRE description.
 Workaround: Click on a different tab and then go back to the JRE tab.
 When you activate the Drag and Drop feature in the Resource Editor to permit you to drag and drop keys into thesource code window, the feature does not work. (369175)
 Impact: You are not able to drag and drop keys into the source code window.
 Workaround: None.
 When you develop a BlackBerry device application using BlackBerry Java SDK 4.7, 4.6.x, or 4.5, Eclipse might exitwhen you hover the mouse over certain classes or methods (such as PersistentContent.addListener) toview the related Javadoc™ description. (501375, 565695, 566182)
 Impact: You might not be able to view all Javadoc descriptions from within Eclipse.
 Workaround: None.
 When you remove a BlackBerry Java SDK from a launch configuration, you encounter a NullPointerExceptionand the launch configuration is corrupted or, when you update the BlackBerry Java SDK without changing thelaunch configuration, you are prompted to save unsaved changes. (560259)
 Impact: You cannot remove or update the BlackBerry Java SDK in an existing launch configuration.
 Workaround: None.
 If there are no preprocessor directives defined in your BlackBerry application project, the Select All and DeselectAll options are still available. (560344)
 Impact: The selection options should not be available if there are no preprocessor directives defined.
 Workaround: None. This behavior does not create any issues.
 When you import an .epf file that you created in the BlackBerry Java Plug-in for Eclipse 1.1.1 into the BlackBerryJava Plug-in for Eclipse 1.1.2, the import fails. (518912 )
 Impact: You cannot import the .epf file from the BlackBerry Java Plug-in for Eclipse 1.1.1.
 Workaround: None.
 Release Notes Known issues
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Find more information 5
 • www.blackberry.com/go/apiref: View the latest version of the API reference for the BlackBerry® Java® SDK.• www.blackberry.com/go/devguides: Find development guides, release notes, and sample application
 overviews for the BlackBerry Java SDK.• www.blackberry.com/go/uiguidelines: Find the UI guidelines for BlackBerry smartphones.• www.blackberry.com/developers: Visit the BlackBerry® Developer Zone for resources about developing
 BlackBerry device applications.• www.blackberry.com/go/developerkb: View knowledge base articles in the BlackBerry Development
 Knowledge Base.• www.blackberry.com/developers/downloads: Find the latest development tools and downloads for
 developing BlackBerry device applications.
 Release Notes Find more information
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Legal notice 6
 ©2011 Research In Motion Limited. All rights reserved. BlackBerry®, RIM®, Research In Motion®, and relatedtrademarks, names, and logos are the property of Research In Motion Limited and are registered and/or used in theU.S. and countries around the world.
 AMD Athlon is a trademark of Advanced Micro Devices, Inc. Eclipse is a trademark of Eclipse Foundation, Inc. Inteland Pentium are trademarks of Intel Corporation. Perforce is a trademark of Perforce Software Incorporated. Javaand Sun are trademarks of Sun Microsystems, Inc. Microsoft, Microsoft ActiveX, Windows, and Windows Vista aretrademarks of Microsoft Corporation. All other trademarks are the property of their respective owners.
 This documentation including all documentation incorporated by reference herein such as documentation providedor made available at www.blackberry.com/go/docs is provided or made accessible "AS IS" and "AS AVAILABLE" andwithout condition, endorsement, guarantee, representation, or warranty of any kind by Research In Motion Limitedand its affiliated companies ("RIM") and RIM assumes no responsibility for any typographical, technical, or otherinaccuracies, errors, or omissions in this documentation. In order to protect RIM proprietary and confidentialinformation and/or trade secrets, this documentation may describe some aspects of RIM technology in generalizedterms. RIM reserves the right to periodically change information that is contained in this documentation; however,RIM makes no commitment to provide any such changes, updates, enhancements, or other additions to thisdocumentation to you in a timely manner or at all.
 This documentation might contain references to third-party sources of information, hardware or software, productsor services including components and content such as content protected by copyright and/or third-party web sites(collectively the "Third Party Products and Services"). RIM does not control, and is not responsible for, any ThirdParty Products and Services including, without limitation the content, accuracy, copyright compliance, compatibility,performance, trustworthiness, legality, decency, links, or any other aspect of Third Party Products and Services. Theinclusion of a reference to Third Party Products and Services in this documentation does not imply endorsement byRIM of the Third Party Products and Services or the third party in any way.
 EXCEPT TO THE EXTENT SPECIFICALLY PROHIBITED BY APPLICABLE LAW IN YOUR JURISDICTION, ALL CONDITIONS,ENDORSEMENTS, GUARANTEES, REPRESENTATIONS, OR WARRANTIES OF ANY KIND, EXPRESS OR IMPLIED,INCLUDING WITHOUT LIMITATION, ANY CONDITIONS, ENDORSEMENTS, GUARANTEES, REPRESENTATIONS ORWARRANTIES OF DURABILITY, FITNESS FOR A PARTICULAR PURPOSE OR USE, MERCHANTABILITY, MERCHANTABLEQUALITY, NON-INFRINGEMENT, SATISFACTORY QUALITY, OR TITLE, OR ARISING FROM A STATUTE OR CUSTOM ORA COURSE OF DEALING OR USAGE OF TRADE, OR RELATED TO THE DOCUMENTATION OR ITS USE, OR PERFORMANCEOR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICESREFERENCED HEREIN, ARE HEREBY EXCLUDED. YOU MAY ALSO HAVE OTHER RIGHTS THAT VARY BY STATE ORPROVINCE. SOME JURISDICTIONS MAY NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES ANDCONDITIONS. TO THE EXTENT PERMITTED BY LAW, ANY IMPLIED WARRANTIES OR CONDITIONS RELATING TO THEDOCUMENTATION TO THE EXTENT THEY CANNOT BE EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, AREHEREBY LIMITED TO NINETY (90) DAYS FROM THE DATE YOU FIRST ACQUIRED THE DOCUMENTATION OR THE ITEMTHAT IS THE SUBJECT OF THE CLAIM.
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TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT SHALL RIM BELIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR ITS USE, OR PERFORMANCE OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICESREFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE FOLLOWING DAMAGES: DIRECT,CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE, OR AGGRAVATED DAMAGES, DAMAGESFOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY EXPECTED SAVINGS, BUSINESS INTERRUPTION, LOSSOF BUSINESS INFORMATION, LOSS OF BUSINESS OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, FAILURES TOTRANSMIT OR RECEIVE ANY DATA, PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN CONJUNCTION WITHRIM PRODUCTS OR SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF RIM PRODUCTS OR SERVICES OR ANY PORTIONTHEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF COVER, FACILITIES OR SERVICES,COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT SUCH DAMAGES WERE FORESEEN ORUNFORESEEN, AND EVEN IF RIM HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
 TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, RIM SHALL HAVE NO OTHEROBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO YOU INCLUDING ANYLIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.
 THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE OF THECAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF CONTRACT,NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A FUNDAMENTAL BREACHOR BREACHES OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY CONTAINEDHEREIN; AND (B) TO RIM AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS, SUPPLIERS(INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED RIM DISTRIBUTORS (ALSO INCLUDING AIRTIME SERVICEPROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.
 IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR, EMPLOYEE,AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF RIM OR ANY AFFILIATES OF RIM HAVE ANYLIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.
 Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to ensurethat your airtime service provider has agreed to support all of their features. Some airtime service providers mightnot offer Internet browsing functionality with a subscription to the BlackBerry® Internet Service. Check with yourservice provider for availability, roaming arrangements, service plans and features. Installation or use of Third PartyProducts and Services with RIM's products and services may require one or more patent, trademark, copyright, orother licenses in order to avoid infringement or violation of third party rights. You are solely responsible fordetermining whether to use Third Party Products and Services and if any third party licenses are required to do so.If required you are responsible for acquiring them. You should not install or use Third Party Products and Servicesuntil all necessary licenses have been acquired. Any Third Party Products and Services that are provided with RIM'sproducts and services are provided as a convenience to you and are provided "AS IS" with no express or impliedconditions, endorsements, guarantees, representations, or warranties of any kind by RIM and RIM assumes no liabilitywhatsoever, in relation thereto. Your use of Third Party Products and Services shall be governed by and subject toyou agreeing to the terms of separate licenses and other agreements applicable thereto with third parties, exceptto the extent expressly covered by a license or other agreement with RIM.
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Certain features outlined in this documentation require a minimum version of BlackBerry® Enterprise Server,BlackBerry® Desktop Software, and/or BlackBerry® Device Software.
 The terms of use of any RIM product or service are set out in a separate license or other agreement with RIM applicablethereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS WRITTEN AGREEMENTS ORWARRANTIES PROVIDED BY RIM FOR PORTIONS OF ANY RIM PRODUCT OR SERVICE OTHER THAN THISDOCUMENTATION.
 Research In Motion Limited295 Phillip StreetWaterloo, ON N2L 3W8Canada
 Research In Motion UK Limited Centrum House 36 Station Road Egham, Surrey TW20 9LF United Kingdom
 Published in Canada
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